In terms of handling this, there is currently a
function under
`src/satosa/util.py` namely `get_dict_defaults()` that favours "" over
"default" – it fallbacks to "default" if "" is not set.
While this is
fine and works, it is not used across the codebase.
I would like to see a standard approach across the codebase.
What are your opinions? Do you think this should
settle to a single
way of representing a default set, even if that means that people
using "" or "default" will have to migrate (this would be a breaking
change for their configs)? Which is the most appropriate way to go?
I think we should migrate to using get_dict_defaults() but change that
method/function so that it favours "default" over "".
The idiom "" is not recognizable to people who are not Python
developers. It looks odd to them and like a sytax mistake or that the
person writing the documentation has forgotten something.
Thanks,
Scott K