[Satosa-dev] Microservices installation

Scott Koranda skoranda at gmail.com
Wed Nov 8 14:38:53 CET 2017


> I would prefer not to have dependencies hard coded (like pysaml1==4.x.x). That
> requires forking the main project because of a changed dependency.
> 

I agree. The dependency on a particular version of pysaml2 has been
bothersome since there has been so much (quite helpful) evolution of
pysaml2 lately and production deployments need the latest release. All
of my production deployments have extra

pip --upgrade pysaml2 

instructions.

I would like to use minimum version dependencies as much as possible and
let pip grab the latest version when available.

Scott K


More information about the Satosa-dev mailing list